summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-03-23 20:31:45 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-03-23 20:31:45 +0100
commit6273649dbd2402bdbe6a465ee5056408adc41924 (patch)
tree2da1e8e5c1953a421171ecd368361e16a6b3b995 /flake.nix
parent5e6421293925721616c97151d6705cb7b2594af3 (diff)
downloadnixos-6273649dbd2402bdbe6a465ee5056408adc41924.tar
nixos-6273649dbd2402bdbe6a465ee5056408adc41924.tar.gz
nixos-6273649dbd2402bdbe6a465ee5056408adc41924.tar.bz2
nixos-6273649dbd2402bdbe6a465ee5056408adc41924.tar.xz
nixos-6273649dbd2402bdbe6a465ee5056408adc41924.zip
...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index c8c4c365..a218d2fe 100644
--- a/flake.nix
+++ b/flake.nix
@@ -166,9 +166,9 @@
166 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); 166 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations));
167 167
168 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; 168 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths;
169 overlays-path = forAllSystems (system: systemPkgs: toString (systemPkgs.writeText "overlays.nix" '' 169 overlays-path = forAllSystems (system: systemPkgs: systemPkgs.writeText "overlays.nix" ''
170 map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)})) 170 map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)}))
171 '')); 171 '');
172 172
173 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages; 173 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages;
174 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages; 174 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages;