summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/xmobar/stackage.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2021-01-03 01:14:47 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2021-01-03 16:21:34 +0100
commit392e6768f9f60c761b65f8774c1667ab8d00f230 (patch)
treee84d0439a01402e3bd85a627c6594526f1d0a8ed /accounts/gkleen@sif/xmobar/stackage.nix
parent4a3d2a8ddaf4e546df360656bc54b2947bdb890b (diff)
downloadnixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar
nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.gz
nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.bz2
nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.xz
nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.zip
gkleen@sif: systemd
Diffstat (limited to 'accounts/gkleen@sif/xmobar/stackage.nix')
-rw-r--r--accounts/gkleen@sif/xmobar/stackage.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/xmobar/stackage.nix b/accounts/gkleen@sif/xmobar/stackage.nix
new file mode 100644
index 00000000..c162ca2c
--- /dev/null
+++ b/accounts/gkleen@sif/xmobar/stackage.nix
@@ -0,0 +1,31 @@
1{ nixpkgs ? import ./nixpkgs.nix {}
2, snapshot ? "lts-13.21"
3}:
4
5let
6 stackage = import (fetchTarball {
7 url = "https://stackage.serokell.io/zb36jsy3r5h4ydz0pnp00g9vk94dvv03-stackage/default.nix.tar.gz";
8 sha256 = "0h6f80gds0ds77y51hhiadh2h2k8njqq8n0gayp729ana9m9agma";
9 });
10
11 overlays =
12 [ stackage."${snapshot}"
13 (self: super: {
14 haskell = super.haskell // {
15 packages = super.haskell.packages // {
16 "${snapshot}" = super.haskell.packages."${snapshot}".override {
17 overrides = hself: hsuper: {
18 zip-archive = self.haskell.lib.overrideCabal hsuper.zip-archive (old: {
19 testToolDepends = old.testToolDepends ++ (with self; [ unzip which ]);
20 });
21 alex = self.haskell.lib.dontCheck hsuper.alex;
22 };
23 };
24 };
25 };
26 }
27 )
28 ];
29
30 inherit (nixpkgs { inherit overlays; }) pkgs;
31in pkgs.haskell.packages."${snapshot}"