summaryrefslogtreecommitdiff
path: root/stack.nix
diff options
context:
space:
mode:
Diffstat (limited to 'stack.nix')
-rw-r--r--stack.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/stack.nix b/stack.nix
new file mode 100644
index 0000000..eec431d
--- /dev/null
+++ b/stack.nix
@@ -0,0 +1,11 @@
1{ ghc, nixpkgs ? (import <nixpkgs> {}) }:
2
3let
4 inherit (nixpkgs) haskell pkgs;
5in haskell.lib.buildStackProject {
6 inherit ghc;
7 name = "stackenv";
8 buildInputs = with pkgs;
9 [ zlib
10 ];
11}