diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -1,13 +1,13 @@ | |||
1 | { nixpkgs ? import <nixpkgs> {}, compiler ? "default" }: | 1 | { nixpkgs ? import <nixpkgs> {}, compiler ? null }: |
2 | 2 | ||
3 | let | 3 | let |
4 | inherit (nixpkgs) pkgs; | 4 | inherit (nixpkgs) pkgs; |
5 | 5 | ||
6 | haskellPackages = if compiler == "default" | 6 | haskellPackages = if compiler == null |
7 | then pkgs.haskellPackages | 7 | then pkgs.haskellPackages |
8 | else pkgs.haskell.packages.${compiler}; | 8 | else pkgs.haskell.packages."${compiler}"; |
9 | 9 | ||
10 | drv = haskellPackages.callPackage ./bar.nix {}; | 10 | drv = import ./default.nix {}; |
11 | in | 11 | in |
12 | pkgs.stdenv.lib.overrideDerivation drv.env (oldAttrs: { | 12 | pkgs.stdenv.lib.overrideDerivation drv.env (oldAttrs: { |
13 | nativeBuildInputs = oldAttrs.nativeBuildInputs ++ (with pkgs; [ cabal2nix gup postgresql ]) ++ (with haskellPackages; [ hlint stack yesod-bin alex ]); | 13 | nativeBuildInputs = oldAttrs.nativeBuildInputs ++ (with pkgs; [ cabal2nix gup postgresql ]) ++ (with haskellPackages; [ hlint stack yesod-bin alex ]); |