summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-06-11 23:00:13 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2016-06-11 23:00:13 +0200
commitbf24ff9ffd25841da5e20386548fb63ff191ed9a (patch)
treebcdfee20698fa0accdbb5dc5457770f45cd19fd0 /default.nix
parent1bdb2f64c92f79918ea5e1a3f98af45e06d4aae7 (diff)
download2017-01-16_17:13:37-bf24ff9ffd25841da5e20386548fb63ff191ed9a.tar
2017-01-16_17:13:37-bf24ff9ffd25841da5e20386548fb63ff191ed9a.tar.gz
2017-01-16_17:13:37-bf24ff9ffd25841da5e20386548fb63ff191ed9a.tar.bz2
2017-01-16_17:13:37-bf24ff9ffd25841da5e20386548fb63ff191ed9a.tar.xz
2017-01-16_17:13:37-bf24ff9ffd25841da5e20386548fb63ff191ed9a.zip
Death & Unconsciousness
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 4b974c3..b496745 100644
--- a/default.nix
+++ b/default.nix
@@ -56,6 +56,37 @@ rec {
56 -- The shell description and utility functions 56 -- The shell description and utility functions
57 -- 57 --
58 2.8.0 58 2.8.0
59
60
61 From 20e394aa3ea287fcaacde9c076c9f49929b28ece Mon Sep 17 00:00:00 2001
62 From: Gregor Kleen <gkleen@yggdrasil.li>
63 Date: Sat, 11 Jun 2016 22:06:36 +0200
64 Subject: [PATCH] Allow modification of state in beforePrompt
65
66 ---
67 src/System/Console/Shell/RunShell.hs | 6 ++++--
68 1 file changed, 4 insertions(+), 2 deletions(-)
69
70 diff --git a/src/System/Console/Shell/RunShell.hs b/src/System/Console/Shell/RunShell.hs
71 index 79ffb54..3e0b95b 100644
72 --- a/src/System/Console/Shell/RunShell.hs
73 +++ b/src/System/Console/Shell/RunShell.hs
74 @@ -217,9 +217,11 @@ shellLoop desc backend iss = loop
75 bst = backendState iss
76
77 loop st = do
78 - flushOutput backend bst
79 + flushOutput backend bst
80 +
81 + runSh st (outputString backend bst) (beforePrompt desc) >>= loop' . fst
82
83 - runSh st (outputString backend bst) (beforePrompt desc)
84 + loop' st = do
85 setAttemptedCompletionFunction backend bst
86 (completionFunction desc backend bst st)
87
88 --
89 2.8.3
59 ''); 90 '');
60 }; 91 };
61 }; 92 };