diff options
author | Gregor Kleen <pngwjpgh@users.noreply.github.com> | 2016-06-25 17:50:37 +0200 |
---|---|---|
committer | Gregor Kleen <pngwjpgh@users.noreply.github.com> | 2016-06-25 17:50:37 +0200 |
commit | 7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2 (patch) | |
tree | 80345b1d7351b179e0b13926c5320c9636183163 /default.nix | |
parent | 5226496a805d58c1bd69df67e8ec8b9e0f05d5a3 (diff) | |
download | 2017-01-16_17:13:37-7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2.tar 2017-01-16_17:13:37-7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2.tar.gz 2017-01-16_17:13:37-7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2.tar.bz2 2017-01-16_17:13:37-7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2.tar.xz 2017-01-16_17:13:37-7a80cf63d55c62a2e5fbf4c937fae4e33f5629c2.zip |
Shellac bump
Diffstat (limited to 'default.nix')
-rw-r--r-- | default.nix | 51 |
1 files changed, 0 insertions, 51 deletions
diff --git a/default.nix b/default.nix index b496745..160dcc7 100644 --- a/default.nix +++ b/default.nix | |||
@@ -7,57 +7,6 @@ rec { | |||
7 | haskellPackages = pkgs.haskell.packages."${compilerName}".override { | 7 | haskellPackages = pkgs.haskell.packages."${compilerName}".override { |
8 | overrides = self: super: { | 8 | overrides = self: super: { |
9 | Shellac = pkgs.haskell.lib.appendPatch super.Shellac (pkgs.writeText "build.patch" '' | 9 | Shellac = pkgs.haskell.lib.appendPatch super.Shellac (pkgs.writeText "build.patch" '' |
10 | From 29c78ed6549525fefb04ae6f7cab8316ac59f3c4 Mon Sep 17 00:00:00 2001 | ||
11 | From: Gregor Kleen <gkleen@yggdrasil.li> | ||
12 | Date: Thu, 2 Jun 2016 17:14:15 +0200 | ||
13 | Subject: [PATCH 1/2] Hiding <$> provided by newer versions of Prelude | ||
14 | |||
15 | --- | ||
16 | src/System/Console/Shell/PPrint.hs | 1 + | ||
17 | 1 file changed, 1 insertion(+) | ||
18 | |||
19 | diff --git a/src/System/Console/Shell/PPrint.hs b/src/System/Console/Shell/PPrint.hs | ||
20 | index e8ec520..8d271e1 100644 | ||
21 | --- a/src/System/Console/Shell/PPrint.hs | ||
22 | +++ b/src/System/Console/Shell/PPrint.hs | ||
23 | @@ -48,6 +48,7 @@ module System.Console.Shell.PPrint | ||
24 | ) where | ||
25 | |||
26 | import System.IO (Handle,hPutStr,hPutChar,stdout) | ||
27 | +import Prelude hiding ((<$>)) | ||
28 | |||
29 | infixr 5 </>,<//>,<$>,<$$> | ||
30 | infixr 6 <>,<+> | ||
31 | -- | ||
32 | 2.8.0 | ||
33 | |||
34 | |||
35 | From 74cb07ccfa92fdcdd6eb3c5871289796ea4981d5 Mon Sep 17 00:00:00 2001 | ||
36 | From: Gregor Kleen <gkleen@yggdrasil.li> | ||
37 | Date: Thu, 2 Jun 2016 17:28:17 +0200 | ||
38 | Subject: [PATCH 2/2] Applicative instance for Sh | ||
39 | |||
40 | --- | ||
41 | src/System/Console/Shell/Types.hs | 2 +- | ||
42 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
43 | |||
44 | diff --git a/src/System/Console/Shell/Types.hs b/src/System/Console/Shell/Types.hs | ||
45 | index 4ec47a9..9efe4b4 100644 | ||
46 | --- a/src/System/Console/Shell/Types.hs | ||
47 | +++ b/src/System/Console/Shell/Types.hs | ||
48 | @@ -74,7 +74,7 @@ type OutputCommand = BackendOutput -> IO () | ||
49 | -- The type parameter @st@ allows the monad to carry around a package of | ||
50 | -- user-defined state. | ||
51 | newtype Sh st a = Sh { unSh :: StateT (CommandResult st) (ReaderT OutputCommand IO) a } | ||
52 | - deriving (Monad, MonadIO, MonadFix, Functor) | ||
53 | + deriving (Monad, MonadIO, MonadFix, Functor, Applicative) | ||
54 | |||
55 | ------------------------------------------------------------------------ | ||
56 | -- The shell description and utility functions | ||
57 | -- | ||
58 | 2.8.0 | ||
59 | |||
60 | |||
61 | From 20e394aa3ea287fcaacde9c076c9f49929b28ece Mon Sep 17 00:00:00 2001 | 10 | From 20e394aa3ea287fcaacde9c076c9f49929b28ece Mon Sep 17 00:00:00 2001 |
62 | From: Gregor Kleen <gkleen@yggdrasil.li> | 11 | From: Gregor Kleen <gkleen@yggdrasil.li> |
63 | Date: Sat, 11 Jun 2016 22:06:36 +0200 | 12 | Date: Sat, 11 Jun 2016 22:06:36 +0200 |