summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-06-02 23:29:36 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2016-06-02 23:29:36 +0200
commit1b7f21ba636e4034f76495deafd0ac6ca9758a4e (patch)
treef8cdffa91a9c6643df51d851d367de0daafb6d5d /default.nix
parente4fe9710287960438856fa78b697ccae64b7e2eb (diff)
download2017-01-16_17:13:37-1b7f21ba636e4034f76495deafd0ac6ca9758a4e.tar
2017-01-16_17:13:37-1b7f21ba636e4034f76495deafd0ac6ca9758a4e.tar.gz
2017-01-16_17:13:37-1b7f21ba636e4034f76495deafd0ac6ca9758a4e.tar.bz2
2017-01-16_17:13:37-1b7f21ba636e4034f76495deafd0ac6ca9758a4e.tar.xz
2017-01-16_17:13:37-1b7f21ba636e4034f76495deafd0ac6ca9758a4e.zip
rudimentary state
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix56
1 files changed, 55 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index ac19354..c96e43f 100644
--- a/default.nix
+++ b/default.nix
@@ -3,6 +3,60 @@
3}: 3}:
4 4
5rec { 5rec {
6 haskellPackages = pkgs.haskell.packages."${compilerName}"; 6 haskellPackages = pkgs.haskell.packages."${compilerName}".override {
7 overrides = self: super: {
8 Shellac = pkgs.haskell.lib.appendPatch super.Shellac (pkgs.writeText "build.patch" ''
9 From 29c78ed6549525fefb04ae6f7cab8316ac59f3c4 Mon Sep 17 00:00:00 2001
10 From: Gregor Kleen <gkleen@yggdrasil.li>
11 Date: Thu, 2 Jun 2016 17:14:15 +0200
12 Subject: [PATCH 1/2] Hiding <$> provided by newer versions of Prelude
13
14 ---
15 src/System/Console/Shell/PPrint.hs | 1 +
16 1 file changed, 1 insertion(+)
17
18 diff --git a/src/System/Console/Shell/PPrint.hs b/src/System/Console/Shell/PPrint.hs
19 index e8ec520..8d271e1 100644
20 --- a/src/System/Console/Shell/PPrint.hs
21 +++ b/src/System/Console/Shell/PPrint.hs
22 @@ -48,6 +48,7 @@ module System.Console.Shell.PPrint
23 ) where
24
25 import System.IO (Handle,hPutStr,hPutChar,stdout)
26 +import Prelude hiding ((<$>))
27
28 infixr 5 </>,<//>,<$>,<$$>
29 infixr 6 <>,<+>
30 --
31 2.8.0
32
33
34 From 74cb07ccfa92fdcdd6eb3c5871289796ea4981d5 Mon Sep 17 00:00:00 2001
35 From: Gregor Kleen <gkleen@yggdrasil.li>
36 Date: Thu, 2 Jun 2016 17:28:17 +0200
37 Subject: [PATCH 2/2] Applicative instance for Sh
38
39 ---
40 src/System/Console/Shell/Types.hs | 2 +-
41 1 file changed, 1 insertion(+), 1 deletion(-)
42
43 diff --git a/src/System/Console/Shell/Types.hs b/src/System/Console/Shell/Types.hs
44 index 4ec47a9..9efe4b4 100644
45 --- a/src/System/Console/Shell/Types.hs
46 +++ b/src/System/Console/Shell/Types.hs
47 @@ -74,7 +74,7 @@ type OutputCommand = BackendOutput -> IO ()
48 -- The type parameter @st@ allows the monad to carry around a package of
49 -- user-defined state.
50 newtype Sh st a = Sh { unSh :: StateT (CommandResult st) (ReaderT OutputCommand IO) a }
51 - deriving (Monad, MonadIO, MonadFix, Functor)
52 + deriving (Monad, MonadIO, MonadFix, Functor, Applicative)
53
54 ------------------------------------------------------------------------
55 -- The shell description and utility functions
56 --
57 2.8.0
58 '');
59 };
60 };
7 sequence = haskellPackages.callPackage ./sequence.nix {}; 61 sequence = haskellPackages.callPackage ./sequence.nix {};
8} 62}