{ config, lib, userName, pkgs, ... }:
{
  home-manager.users.${userName} = {
    home.packages = with pkgs; [ yt-dlp ];
    xdg.configFile."yt-dlp/config".text = ''
      --netrc
      --mark-watched
      --format ${lib.concatStringsSep "/" [
        "bestvideo[width<=3840][height<=2160][fps<=60]+bestaudio"
        "best[width<=3840][height<=2160][fps<=60]"
        "best"
      ]}
      --sub-langs all,-live_chat
      --prefer-free-formats
      --embed-metadata
      --downloader ${pkgs.aria2}/bin/aria2c
    '';
  };
}