{ userName, pkgs, lib, ... }:
{
  home-manager.users.${userName} = {
    programs.tmux = {
      enable = true;
      clock24 = true;
      historyLimit = 50000;
      extraConfig = lib.readFile (pkgs.stdenv.mkDerivation {
        name = "tmux.conf";
        src = ./tmux.conf;

        buildInputs = with pkgs; [ makeWrapper ];

        phases = [ "installPhase" ];

        inherit (pkgs) zsh;
        mandb = pkgs.man-db;
        
        installPhase = ''
          substituteAll $src $out
        '';
      });
    };

    home.packages = [
      pkgs.tmuxp
    ];
  };
}