{ config, flakeInputs, pkgs, lib, userName, customUtils, ... }:
{
  home-manager.users.${userName} = {...}: {
    imports = [
      (customUtils.overrideModuleArgs
        (import ./module.nix)
        (inputs: inputs // { inherit flakeInputs; inherit (config.nixpkgs) system; })
      )
    ];
  };
}