{ system, self, ... }:

let
  pkgs = self.legacyPackages.${system};
in
with pkgs.poetry2nix;
mkPoetryApplication {
  projectDir = cleanPythonSources { src = ./.; };

  nativeBuildInputs = with pkgs; [ makeWrapper ];

  overrides = overrides.withDefaults (self: super: {
    pyyaml = super.pyyaml.override { preferWheel = true; };
  });

  postInstall = ''
    wrapProgram $out/bin/sops-inventory \
      --prefix PATH : ${pkgs.lib.makeBinPath (with pkgs; [git])}
  '';
}