{ final, prev, sources, ... }: {
  xcompose = prev.stdenv.mkDerivation (sources.xcompose // {
    nativeBuildInputs = with final; [ perl ];

    postPatch = ''
      substituteInPlace emojitrans2.pl --replace "/usr/bin/env -S perl -p" "${final.perl}/bin/perl -p"
    '';

    installPhase = ''
      mkdir -p $out
      install -t $out \
        dotXCompose frakturcompose \
        emoji.compose modletters.compose tags.compose maths.compose parens.compose
    '';
  });
}