{ mkDerivation, aeson, aeson-casing, attoparsec, base, bytestring
, case-insensitive, containers, cryptonite, exceptions, file-embed
, filepath, hpack, http-api-data, http-types, jose, lens
, lens-aeson, lib, mmorph, monad-logger, MonadRandom, mtl
, optparse-applicative, path-pieces, persistent
, persistent-postgresql, random, servant, servant-server
, template-haskell, text, th-lift-instances, time, transformers
, unliftio-core, unliftio-pool, uuid, vector, wai, wai-app-static
, wai-extra, warp, warp-systemd
}:
mkDerivation {
  pname = "spm";
  version = "0.1.1";
  src = ./.;
  isLibrary = true;
  isExecutable = true;
  libraryHaskellDepends = [
    aeson aeson-casing base case-insensitive containers jose lens
    lens-aeson servant text uuid
  ];
  libraryToolDepends = [ hpack ];
  executableHaskellDepends = [
    aeson attoparsec base bytestring case-insensitive cryptonite
    exceptions file-embed filepath http-api-data http-types jose lens
    lens-aeson mmorph monad-logger MonadRandom mtl optparse-applicative
    path-pieces persistent persistent-postgresql random servant-server
    template-haskell text th-lift-instances time transformers
    unliftio-core unliftio-pool uuid vector wai wai-app-static
    wai-extra warp warp-systemd
  ];
  prePatch = "hpack";
  license = lib.licenses.agpl3Plus;
}