final: prev:
let
  mucHistory = prev.fetchpatch {
    url = "https://developer.pidgin.im/raw-attachment/ticket/16524/0001-only-request-unseed-chat-history-from-jabber-group-c.patch";
    sha256 = "083wvmq7417xz55fxxhllqwql1hgjvin2sak08844121yw1jvc44";
  };
in {
  pidgin-with-plugins = import (/. + prev.path + "/pkgs/applications/networking/instant-messengers/pidgin/wrapper.nix") {
    inherit (prev) makeWrapper symlinkJoin;
    plugins = with final; [ purple-lurch pidgin-carbons pidgin-opensteamworks pidgin-xmpp-receipts ];
    pidgin = prev.pidgin.overrideAttrs (oldAttrs: {
      patches = (oldAttrs.patches or []) ++ [mucHistory];
    });
  };
}