{ config, lib, pkgs, ... }:

{
  imports =
    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
    ];

  fileSystems."/" =
    { device = "/dev/hel/btrfs";
      fsType = "btrfs";
      options = [ "compress=lzo" "discard" "defaults" ];
    };

  fileSystems."/boot" =
    { device = "/dev/disk/by-uuid/3ADC-E1CD";
      fsType = "vfat";
    };

  swapDevices =
    [ { device = "/dev/hel/swap"; }
    ];

  nix.maxJobs = lib.mkDefault 4;

  hardware.cpu.intel.updateMicrocode = true;
}