{ stdenv
, fetchgit
}:

let
in stdenv.mkDerivation {
  name = "prosody-auth";
  src = fetchgit {
    url = "git://git.yggdrasil.li/prosody_auth";
    rev = "0d4b0b7b4d538a16e57f7106b6dc878788123333";
    sha256 = "ec4f79ec4b3f46ebb8bb05089657a699872b1a45a1a7edbb019485401010b33d";
  };
  builder = builtins.toFile "builder.sh" ''
    source $stdenv/setup

    mkdir -p $out
    cp -rv $src/mod_auth_custom $out
  '';
}