{ pkgs, ... }:
{
  config = {
    services.swayosd = {
      enable = true;
      topMargin = 0.946154;
      stylePath = pkgs.runCommand "style.css" {
        src = pkgs.writeText "style.scss" ''
          window#osd {
            padding: 12px 20px;
            border-radius: 999px;
            border: none;
            background: rgba(0, 0, 0, 0.87);

            #container {
              margin: 16px;
            }

            image,
            label {
              color: rgb(255, 255, 255);

              &:disabled {
                opacity: 1;
                color: rgb(84, 84, 84);
              }
            }

            progressbar {
              min-height: 6px;
              border-radius: 999px;
              background: transparent;
              border: none;

              trough, progress {
                min-height: inherit;
                border-radius: inherit;
                border: none;
              }

              trough {
                background: rgb(127, 127, 127);
              }
              progress {
                background: rgb(255, 255, 255);
              }

              &:disabled {
                opacity: 1;

                trough {
                  background: rgb(19, 19, 19);
                }
                progress {
                  background: rgb(38, 38, 38);
                }
              }
            }
          }
        '';
        buildInputs = with pkgs; [sass];
      } "scss -C --sourcemap=none --style=compact $src $out";
    };
  };
}