{ config, lib, ... }:
{
config = {
services.mako = {
enable = true;
font = "Fira Sans 10";
format = "%s\\n%b";
margin = "2";
maxVisible = -1;
backgroundColor = "#000000dd";
progressColor = "source #223544ff";
width = 384;
extraConfig = ''
outer-margin=1
max-history=100
[grouped]
format=(%g) %s\n%b
[urgency=low]
text-color=#999999ff
[urgency=critical]
background-color=#900000dd
[app-name=Element]
group-by=summary
[mode=silent]
invisible=1
'';
};
systemd.user.services.mako = {
Unit = {
Description = "Mako notification daemon";
PartOf = [ "graphical-session.target" ];
};
Install = {
WantedBy = [ "graphical-session.target" ];
};
Service = {
Type = "dbus";
BusName = "org.freedesktop.Notifications";
ExecStart = lib.getExe config.services.mako.package;
RestartSec = 5;
Restart = "always";
};
};
};
}