summaryrefslogtreecommitdiff
path: root/sif.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sif.nix')
-rw-r--r--sif.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/sif.nix b/sif.nix
index 1b09f218..2e82ee1f 100644
--- a/sif.nix
+++ b/sif.nix
@@ -121,6 +121,22 @@
121 }; 121 };
122 }; 122 };
123 123
124 nixpkgs.overlays = [
125 (self: super: {
126 linuxPackages_latest = super.linuxPackages_latest.extend (self: super: {
127 nvidia_x11 = super.nvidia_x11.overrideAttrs (attrs: {
128 patches = [
129 (pkgs.fetchpatch {
130 name = "nvidia-kernel-5.7.patch";
131 url = "https://gitlab.com/snippets/1965550/raw";
132 sha256 = "03iwxhkajk65phc0h5j7v4gr4fjj6mhxdn04pa57am5qax8i2g9w";
133 })
134 ];
135 });
136 });
137 })
138 ];
139
124 services = { 140 services = {
125 pcscd.enable = true; 141 pcscd.enable = true;
126 142