summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/odin.nix b/odin.nix
index b1fa8193..f3516007 100644
--- a/odin.nix
+++ b/odin.nix
@@ -534,17 +534,18 @@
534 users.groups.ssl = {}; 534 users.groups.ssl = {};
535 users.users.nginx.extraGroups = ["ssl"]; 535 users.users.nginx.extraGroups = ["ssl"];
536 536
537 services.prometheus = { 537 services.prometheus.exporters = {
538 node = {
539 enable = true;
540 listenAddress = "localhost";
541 enabledCollectors = [ "logind" "systemd" "processes" ];
542 };
543 };
544
545 services.prometheus2 = {
538 enable = true; 546 enable = true;
539 webExternalUrl = "http://odin.asgard.yggdrasil/prometheus"; 547 webExternalUrl = "http://odin.asgard.yggdrasil/prometheus";
540 listenAddress = "localhost:9090"; 548 listenAddress = "localhost:9090";
541 exporters = {
542 node = {
543 enable = true;
544 listenAddress = "localhost";
545 enabledCollectors = [ "logind" "systemd" "processes" ];
546 };
547 };
548 globalConfig = { 549 globalConfig = {
549 scrape_interval = "5s"; 550 scrape_interval = "5s";
550 scrape_timeout = "5s"; 551 scrape_timeout = "5s";