diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix new file mode 100644 index 0000000..50b8196 --- /dev/null +++ b/shell.nix | |||
@@ -0,0 +1,15 @@ | |||
1 | { pkgs ? (import <nixpkgs> {}) | ||
2 | , haskellPackages ? pkgs.haskellPackages | ||
3 | }: | ||
4 | |||
5 | let | ||
6 | ghc = haskellPackages.ghcWithPackages (ps: with ps; [ mtl ]); | ||
7 | in | ||
8 | pkgs.stdenv.mkDerivation rec { | ||
9 | name = "gausshs-env"; | ||
10 | buildInputs = [ ghc ]; | ||
11 | shellHook = '' | ||
12 | eval $(egrep ^export ${ghc}/bin/ghc) | ||
13 | export PROMPT_INFO="${name}" | ||
14 | ''; | ||
15 | } | ||